• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

HELP!!! Trouble connecting ReadyToFlyer 2.8 to Mac running OSX 10.10.1 (Yosemite)

#1
Pretty simple: my mac simply does not recognize when the ReadytoFlyer 2.8 is plugged in. I'm using APM Planner, which will acknowledge my USB telemetry module, but it doesn't even show that anything is connected when I plug in the ReadToFlyer. I checked using the stock USB Prober application and it doesn't show any USB device connected.

ReadyToFlyer 2.8 is an APM 2.6 clone. I know the device is functional because I can receive data from it using telemetry, but I can't install new firmware without a direct connection.

I've tried installing the newest FTDI drivers several times. Also, worth noting, the Arduino Mega 2560 will no longer connect to my Mac either (this board uses the same chip as the ReadyToFlyer). However, a normal Arduino Uno board will connect, and is recognized by USB Prober, the Arduino IDE, and APM planner (although it's not actually compatible).

My computer is a MacBook Pro (Early 2011) running OSX 10.10.1 (Yosemite). I mention this because the arduino Mega used to work with my computer, but no longer works. Whatever broke that functionality, may have also stopped my connection with the ReadyToFlyer 2.8 board.

Has anyone had this problem before? Any solutions?
 

makattack

Winter is coming
Moderator
Mentor
#2
I don't have a mac, but you didn't mention the port you selected and the baud rate over usb. You do have to change it when using usb vs the telemetry radio.
 
#3
FTDI drivers won't make a difference to connect to the RTF 2.8 through USB. You only need to install the FTDI drivers to use the telemetry radio. And if telemetry is already working for you, then the FTDI drivers are working.

Connecting my RTF 2.7 to my mac with USB is a little bit fussy. Make sure you connect the USB cable before you open the APM Planner application. If APM Planner is already open, quit the app and then reconnect the USB cable. I think it's a bug in APM Planner, and closing the app before connecting solves the problem.

In APM Planner on my mac, I always have to click the port selection box in the top right near the "Connect" button. (Click that middle box, that says "usbmodem." It'll say something different if you're using the telemetry radio, but you need it to say "usbmodem" to connect to your RTF through USB.)
Screen Shot 2014-12-22 at 10.28.16 PM.png

Then in the dialog window, make sure you've selected the USB modem and click Connect.
Screen Shot 2014-12-22 at 10.28.26 PM.png

This is the only way it works for me in OS X Yosemite. If I don't quit the app before connecting the USB cable, or if I don't open the connection dialog window, clicking the "Connect" button on the main screen does nothing, even if the usbmodem is already selected. I don't have a telemetry system, so I don't know if switching back and forth between the radio and the USB connection makes a difference, or if you need to use two different baud rates. (115200 works for me on USB.) But my suggestion is still to quit APM Planner, connect the USB cable, and then reopen the program and use the connection dialog window.

For what it's worth, I've given up using APM Planner in OS X. I run Windows 7 on my mac with boot camp, and use that for all my RC software. (Mission Planner, APM Planner, APM Log Analyzer, Phoenix Simulator, MinimOSD configuration tool, Mobius software, OpenTX Companion, yadda yadda yadda.) APM Planner OSX has worked fine for me on almost everything I wanted to do with my APM, but I had a problem getting my APM to talk with my MinimOSD, and Mission Planner in Windows fixed it, but APM Planner in OSX couldn't. I don't have any of these USB connection problems running windows in boot camp.
 
Last edited:
#4
Thank you for the suggestions. I tried plugging it in before launching the program but had no luck. It simply doesn't show up as an option in my ports. I get the feeling that the problem is no exclusive to APMs, because my arduino megas stopped working after I ungraded to yosemite.

I will try it on some PCs and if I have luck with that I may go for the bootcamp. There are so many apps that require it anyway.

Screen Shot 2014-12-22 at 11.14.56 PM.png
 
#5
Oh, one more thing. You might want to try plugging the USB cable directly into your MacBook, and not through a hub. (Unless you're already doing that.) In windows, I get an error message if I plug the APM in to my keyboard's USB port, but it's fine if I plug it directly into my iMac. When you plug the APM in through USB, it's getting its 5v power through USB, which means it can pull a pretty big draw if you're using a hub.
 

RichB

Senior Member
#6
It's been a while since I played with my APM, but I think you need to unplug the telemetry module from the APM to use the USB port.

Pretty sure they share the same serial pin on the ATMEGA chip.
 
#8
Still no luck, even plugging the bare board to my laptop directly. I am working on the bootcamp right now, but it's not so easy because my laptop's a little old.
 
#10
PROBLEM SOLVED!!!! As it turns out the USB to micro USB cable I was using was from a cheap phone charger. So cheap in fact, that the cable didn't even have the data lines. Just 5V and ground. I switched out the cable and I'm all set. Thanks for all the advice though. I'm sure this thread will come in handy for someone down the line!

The Arduino Mega still refuses to connect, but I'm not alone on that issue, so I'm sure someone will find a solution eventually.