• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Hovership 3dFly & Spektrum Tx

Stampede

Junior Member
#1
Hi All,

I just got my first drone kit, a 3d Fly Hovership kit with Spektrum DX5e transmitter. I can't seem to get the Transmitter synced with the Receiver, anyone have have any advice?
The kit comes with a lemon RX, and everything is supposed to be pre-programmed out of the box. The lemon rx doesn't have any pins, or bind pins to do the suggested sync method that's described in the Spektrum manual.

Can't wait to get my first drone flying!

Thx,
 

pressalltheknobs

Posted a thousand or more times
#2
It may be a Satellite receiver and possibly you have to bind it though the flight controller. Generally satellite receivers can only be bound via the main receiver but some flight controller software can bind them too. I don't have one, just what I've read.

If it's is all supposed to be pre-bound then first check the manual to see if there is a procedure to re-bind it and if not contact the company you bought it from and ask them.

If that doesn't work try, to get the brands and models of the components you have and maybe post some pictures.
 

Snarls

Gravity Tester
Mentor
#3
Hi Stampede, welcome to the forum! The flight controller of the 3D fly is a Beef's Brushed Board (BBB32). It runs Cleanflight which can bind the lemon sat without needing a parent RX. Here is the manual. You just have to put some commands in the CLI, restart the board in bind mode, and write some more CLI commands. Check it out here.

The 3DFly looks like a nice kit, and gets me thinking about making a micro quad. Let us know how it flies!
 

Stampede

Junior Member
#4
Thanks, For some reason I though it was all preset. Thanks for illuminating that for me!

Yea I'm really excited to try it out, it's my first quad but I will definitely post back with more info.

Thanks!


:edit:
..wow I can't believe I overlooked the giant, bold, title on the BBB page "Spektrum BINDING:"
Ouch.
I will give the full programming walk through a go. Looking forward to getting airborne. Now to find an FPV camera!
 
Last edited:

Stampede

Junior Member
#5
Just curious, has anyone run CleanFligh on Ubuntu? I have it installed, it just keeps bouncing back that failed to open serial port.

I ran the command sudo usermod -aG dialout username, no luck.

I'll post the answer if I find it.
**** Update

So running Ubuntu 16.04, I installed Chromium from the Ubuntu Software Store.
I then Installed the extension for CleanFlight
I ran the command for sudo usermod -aG dialout username
I logged off of the username, then logged back in.

I've also tested this using regular Google Chrome and it also works fine.

Another thing that tripped me up was flashing the board, make sure your USB FTDI is connected to your computer and board. Then choose any NAZE firmware from the drop down menu. Click load firmware online, then click flash firmware. I guess this loads a firmware on the board that allows connectivity to take place to the CleanFlight software. I was nervous about this, I didn't want to wipe the board or mess it up, but it's OK.
 
Last edited:

Stampede

Junior Member
#6
Binding Completed

Another update, in the Spectrum Binding instructions,

After starting the bind process using the bind command in CLI I noticed that the instructions on the BBB32 page asked to turn the transmitter on first. The DX5e manual has the instructions the other way. Meaning Turn the RX on first then turn on the receiver. I did the DX5e method and it worked for me.

This is my first multirotor, and first RC anything so I figured others who are starting cold like me can use some extra tips! Hopefully google will index this for any future travellers.

Now, when I tried to start my multirotor I didn't get anything, so I'm recharging the battery. Maybe it was low. When I first got it assembled I connected it to the battery and the motors went wild. Luckily no propellers were installed, or else I'd still be trying to scrape it off the ceiling.
 
Last edited:

Stampede

Junior Member
#7
So everything looks right in the software, but when I went to do my maiden voyage nothing happened. I connected the battery and the motors and gave it throttle on the transmitter, and nothing happened. The lemon RX was lit up solid, which I believe means that it is bound and ready to receive comm.

Any advice? I went through the firmware process 2 more times and even flashed an older NAZE image to make sure it wasn't a bad firmware issue. At the end of each setup I was able to see the Transmitter input on the Receiver tab. So comm is setup and happening. I lock the bind and try for lift off with no effect.

Almost There!! I Reached out to Hovership for support, I will post my results. Hopefully something basic.
 
Last edited:

Snarls

Gravity Tester
Mentor
#8
Are you arming the board? You have to push the left stick down and to the right (assuming mode 2) for a second to arm it.
 

Stampede

Junior Member
#9
Ah ! no i haven't armed the board!

Thank you for filling me in, I'm so clueless about all this.

Arming didnt work tho. I do believe this is a Mode 2 Tx. I hold down the left stick in the South East corner for a few seconds but no result.

**Reading online I'm going to run through the settings make sure I didn't miss anything that could be preventing Arming.
 
Last edited:

Snarls

Gravity Tester
Mentor
#10
Ok connect to Cleanflight without battery and try the arming motions. See what the throttle and yaw values read. Go to the CLI and look up 'min_check' . It should be a value that is above your lowest throttle value. If it is not 'set min_check =' something slightly higher than your lowest throttle value.
 
#11
Ok, I set the min_check value to 1020, when tucked into the SE corner the throttle reads 988 and the yaw reads 1176.
Then I disconnected and tried to start the quad but it did not work.

I found the motors tab so I was able to test the motors do infact still work.
 
#12
Getting close! So I set the min_check slightly above the Yaw value of 1171. So I set it to 1200. Now when I go low and to the right on the left stick and low and to the right on the right stick the board flashes green a number of times, but it doesn't stay solid. It's like it wants to arm, but it doesn't lock.

When I put the min check lower like 1100 I don't get that reaction, when I put the min_check up to 1200 it blinks. 1300 doesn't give me anything.
 

Snarls

Gravity Tester
Mentor
#13
Ok if your lowest throttle is 988 then a min_check of as low as 1000 should work. That said what are your channel endpoints? Every channel should be going from around 1000 to 2000, with center being at 1500. If the max yaw (all the way to the right) is 1176 then it is way off from the desired 1900-2000 needed to arm. If adjusting the end points doesn't work, could you post a screenshot of of your receiver tab in cleanflight. Also make sure you have calibrated the acceleratorometer. Simple but some people forget.
 
#14
Hey Snarls,
Interesting, when I flick the stick to the bottom right I believe I get the lowest throttle and lowest yaw values. I'll double check that when I get home later. but 1176 was my yaw low, that I know.
The max throttle I believe defaults to 1850 in the config tab.
Again I'm like studying shadows on a wall and trying to infer what they mean, but I went through Min_check values and anything greater or equal to 1185 caused the board to react when I tried to arm it. The LED would flash as though it's trying to start but doesn't go solid to say we're running. Anything below 1185, like 1000 did not get any response.
I did calibrate the acceleratorometer but I will re-run the calibration when I try again later.

Thanks!!
 

Snarls

Gravity Tester
Mentor
#15
Oh, perhaps your yaw is reversed. To the right should read the higher values. Cleanflight is checking for a yaw value above 1900 for it to arm. If you want to lower that value you change 'max_check'. Currently when you get the LEDs on the board those are the LEDs for disarming. So reverse your yaw channel and try again. You can also test if its a yaw thing by putting the arm on a switch and using a switch to arm.
 

Stampede

Junior Member
#16
Ok, Success. Partially....

So yaw goes low, left stick to the left, and high, left stick to the right.
I set min_check to 1200 my lowest yaw value is 1185.
I set max_check to 1800 my highest yaw value is 1804.

Now my quad arms when I place the left stick bottom left for a few seconds. It disarms when I go left stick bottom right.

Thanks again for your help snarls!!!


Now there wasn't enough throttle to get the quad airborne for some reason. It got loud but not strong enough. It was like a buzzing brick, lol. I'm going to tweak my throttle see if I can give it a little more or set it higher. I'm just using the kit parts so it really should be able to fly, lol.

Charging the battery now to make sure we're at full power.

Thanks!
 

Stampede

Junior Member
#17
At last! ok, so i reset the accelorometer calibration again. Then I went and switched my props around. It was moving a lot of air but it was basically pinning itself to the ground. After a few combinations of prop changes we have lift off!! Boy is it squarely!! I'll have to dial it in some more but it runs great!
Already broke a prop doing some intense freestyle acrobatics in my kitchen. Let's just say it was freestyle rather than not knowing my @@ from my elbow, and causing it to flip upside down and careen into the refrigerator. There are definite style points in there somewhere...

Thanks so much for everyone's help getting me up and going! I couldn't have done it without your help.