• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

I need help with my new Versacopter V2 Naze32 rev 6 RPM trouble

Kyle

Junior Member
#1
So this is my first Quadcopter build though I have built and flown planes for years. I built the new Versacopter V2 while watching the build video and the Naze32 video from flitetest. I calibrated everything per the video and flitetest tech support. When I have it hooked up to cleanflight (no props) in the motors tab so I can watch the speed, arm it and the motor come up to minimum speed roughly 1075. With just two clicks of throttle, motor (in position) #3 runs up to nearly 1800. I have tried to swap motors with same result and swapped ESCs with same result which leads me to think it is in the NAZE32 board or my radio. If I simply arm it and pick up the versacopter and move it around, the correct motor speeds up and then slows back down. Also if I move the right stick the correct motor speeds up and slows down as it should. It is only when I give it throttle of any amount that motor position #3 "runs away". The radio I am using is a Futaba T9CAP with the Spektrum module and an AR7010 receiver, so I set everything up for Spektrum. Any advice would be greatly appreciated, I really want to fly this thing!!


In case anyone else is having this problem... I fixed it. I ordered a new NAZE32 board and flashed it with Baseflight. It still won't fly stable in horizon mode when flashed with Cleanflight so I'm sticking with Baseflight and it flies GREAT!!!
 
Last edited: