• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Inav support for FC

#1
Hey everyone.
I've got a Frsky omnibus Fireworks f4 v2 flight controller which I'm planning to power a Kracken with. It comes with betaflight but I've been told INav has better support for fixed wings and gps functioning. The only issue is there are many Inav firmware that look close. I think the one I should use is the fireworks v2 but this is for the airbot variant. Mine has an in inbuilt frsky 2.4gh telemetry recover. I'm worried if I flash the firmware the receiver wont work. Can anyone shed some light? Cheers
 

Fluburtur

Cardboard Boy
#2
Inav supports a bunch of FCs so your should be in there, also it can support plenty of receiver protocols so you should be fine. Can't say for sure for your specific FC but you should be fine, anyways you can search the internet about that because you are maybe not the only one to do that.
 

ElectriSean

Eternal Student
Mentor
#3
I believe the fireworks v2 target is the one you're after. Setting up the receiver will be the same as if it were non-integrated.
 

IanSR

Active member
#7
Yes, you can't actually brick these, the bootloader is stored in ROM.
Is that true? I've got an unbranded (LemonF405) FC but there is no specific build for it, I was thinking of just trying to flash the Matek build to it (since the board is claimed to be a clone of the f1405), but I don't want to brick it lol
 

ElectriSean

Eternal Student
Mentor
#8
Is that true? I've got an unbranded (LemonF405) FC but there is no specific build for it, I was thinking of just trying to flash the Matek build to it (since the board is claimed to be a clone of the f1405), but I don't want to brick it lol
The worst that can happen is it just won't work, you can always flash a different version or target. If your board is a proper clone, the matek target will work. The main difference between targets (builds for different boards) is how they assign resources and map what is connected where.
 
#10
Well the board arrived and I had a play with the board in betaflight and then tried to flash Inav. Flash worked just fine but then I couldn't connect to the board. It could fine the com port fine and but then states unable to load configuration in 10 seconds. Tried flashing with different settings like full erase and flash on connect but couldn't get it to work. Flashed betaflight omnibusf4fw back on it and works fine again. I think it may be some kind of driver conflict but works fine in betaflight but issues in inav. I've no idea why.
 

ElectriSean

Eternal Student
Mentor
#11
Probably not a driver issue if it works in BF. Could be the wrong target, but I would be surprised if that was it... I always do the full chip erase as this erases the old config from EEPROM. I'd try again, if it still gives issues try unplugging/plugging in the USB, and/or try rebooting. If all that fails you can try opening an issue with the devs - https://github.com/iNavFlight/inav/issues
 

IanSR

Active member
#12
Try a different usb port and give it time first plugin, it can often take up to three minutes while Windows installs the drivers before its recognised and useable.
 
#13
Tried all suggestions and couldn't get it working. I'll open a dev issue. For the time being I'll use betaflight. Might not be as good for gps stuff but should get me airborne and has return to home now.