• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Naze32 + Cleanflight - Motors spin rapidly up and stop

snoato

Junior Member
#1
Well, it's me again... I've got a new problem with my 230mm quad...

First of all, I got it flying for like 4 minutes yesterday, which is good, it flew pretty well. When I tried it later that day again it started showing some weird behaviour:
When I arm it, the motors start spinning at minimum thrust, which is the way it's meant to be as I understand. However when I start to increase throttle it spins up rapidly by itself after a few seconds, jumps in the air, lands and doesn't let me control throttle anymore. Only after setting throttle to zero and/or disarming and arming again I can control the throttle after that happens. It doesn't only happen if the quad is on the ground, if it's airborne before this happens, it will happen mid air and crashes my quad. Sometimes it takes 20 seconds and sometimes only one.
I tried recording it with blackbox and filming it and it seems like it's getting a peak on throttle input for the fracture of a second, but I don't know why.
I use a Turnigy 9x Tx and the Rx which comes with it, 12A Afro ESCs, 5030 props and the Naze32 rev 6 with Cleanflight on it.

If anyone has any idea it would be awesome since I really want it to fly again like it did yesterday.

Here's the video:

Thank you so much.
 

snoato

Junior Member
#2
Ok I think I solved it. The problem was that the cable connecting the Rx and the Naze was mounted in a way that didn't prevent it from changing it's position midflight which somehow created ghost values. I mounted it steadier now, which seems to solve the problem.