• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Need some help! multi rotor (motor problem)

#1
Hello people of the internet,

I am in need of a little bit of help, (feel free to skip intro) Let me explain my problem and hopefully someone with lot more knowledge than myself will be able to help me out or show me a way. So I bought the multi-rotor a while back but had to wait for the controller to arrive and for me to finish uni for me to play with my new toys, With uni finished I expected to be up in the air in no time.... Thus I was wrong! Connected it to my controller (turnigy 9x) fiddled with settings, (further down full list) calibrated the motors, all that jazz! Tied it to a wooden pallet so that if the unlikely happened and it took off I wouldn't loose it somewhere over Wales...... Point two I was being optimistic, armed the motors stood back for spectacular show of power and..... got about 25-30% max power and it not even to shuffle around on the pallet. In my despair I took to YouTube to find the answer and came back with naf all so looking from help from people who know the hobby inside out and upside down like you guys! :D

So just as side note:
Motors are spinning correct ways
Props are one the right way
I have noticed that the throttle still isn't changing the speed of the motors at all from about 5% throttle the motors spin up to about 25-30% and will remain spinning at the speed regardless of the throttle if i however yaw,rudder etc the speed changes in the direction i'm telling it as if it was flying, the motors also change direction if I lean it to try simulate wind and it tries to level its self out again. (all of these tests are the same with and without the props)

Can send video if needed to help understand


Right important stuff:
Multi Rotor setup
Hardware:
  • 800MM HEXACOPTER frame
  • 8x RCTIMER 5010 530 KV MOTORS
  • 8x GRAUPNER 14 INCH PROPS
  • 8x 45 AMP OPTO ESCS
  • Aurdocopter v2.8 (APM V 2.8)
  • NEO 7 GPS
  • TURNIGY RECEVIER 2.4GHz 9X8C v2
  • FLOUREON® 11.1V 5500mAh 3S 35C Lipo Battery

For the full list Click here >https://docs.google.com/document/d/1CG4cm21a1ql2Ld_7hApdIK1x6veqhIFkVDg5Y80XSt4/edit?usp=sharing



Many thanks
Peter
 

pressalltheknobs

Posted a thousand or more times
#2
well I'm not an expert on that stuff but it sounds like the control board is stuck in some hover or safe mode.

If you have a servo tester you can test your ESCs and motors separately from the control board to convince yourself they are working properly. You can also connect the esc control lines direct to the RX and check your TX and RX can power them all up as you expect. You can just do the 2nd one if you don't have a servo tester. I'm sure that's all good but it narrows things down to being the controller programming and since its easy to do, its always good to confirm that subsystems are working so you don't miss the obvious.

Can't tell you what to look for after that except to go through whatever you did to set up the control board and make sure you didn't miss a step and you understand what mode it starts up in etc.

Probably I would disconnect the GPS and disable the control board from reading it until you have the basic control functions working. It's probably not part of the problem but the less moving parts you have the easier it is to find the fault. Just don't forget to enable it all again before you fly it off into the sunset.
 

pressalltheknobs

Posted a thousand or more times
#3
oh and check you battery is fully charges and balanced just in case. Again an easy thing to check that can get overlooked and waste a lot of time if it's bad.
 
#4
Thanks pal,
So I double checked all the batteries all good, double checked ESC's worked fine..disconnected the GPS and it worked so plugged it back in and it seems to still be working... Thanks you for the help, now just to take it really slow and get her flying again, not to sure what I actual did to fix it which would of been nice so that I could help others that might get the same problem[/B but if anyone reading this gets the same problem or similar do one fix at a time or you will be chasing your tail like I did, and asking the community for help is awesome lots of smart people out there.