• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

New Quad problem. motors? escs? fc??

bwb0440

Junior Member
#1
Did my Flip32 S**t the bed??? or the motors/esc's???

Hey guys! Im new to the multirotor world, I just built my first quad and finally got it up in the air the other day with zero issues without any tuning. but after my first flight i ran into some (what appears to be) serious issues. if you can take the time to read my little story and help me out that'd be amazing. ive read lots of threads on all forums trying to diagnose my problem, so ive decided to post a thread.

its the emax blackhawk (full cf)
emax simonk 12a escs
emax MT2204 2300KV motors.
flip32 acro
turnigy 9x rx/tx

so. towards the end of my first flight i crashed a couple times. first crash put a slight crack in the middle plate. got it back in the air no issues. second crash (not serious) i flew it too far away LOS and couldnt tell its orientation in acro mode. bout 10 feet up. i cut the power figured it wont hurt. it landed on the left two arms at a slight angle in the grass. no visual damage. seemed fine. so i called it a day because my batteries were just about dead.

later on that night i decided to hover it around my apartment and show it off to a buddy of mine. plugged in a fresh battery. armed the board. and gave it throttle. immediately i knew something was wrong. all the motors were all out of sync, a couple were twitching then wouldnt spin at all with about 20-30% throttle. then the other motors would increase in rpm dramatically. huh... strange. i visually inspected it and all the wires, conenctions, solder connections seemed fine. i decided to leave it alone and figure it out when i had some spare time.

the following day (today) i plugged it into cleanflight. the board sat level and straight on cleanflight. i then went over to the motor tab. decided to ramp up each motor till they began to spin. one spun up at 1165. another at 1165. the other two would twitch before spinning up at 1175 or 1185. then the motor spinning up at 1165 would twitch. sometimes they would twitch other times they wouldnt. huh. i decided to use to master slider and ramped up all motors and they would start up inconsistently, at 50% throttle i could hear motors 2 and 4 spin slightly faster than 1 and 3. i then decided to recalibrate the esc's. and they'd all sing the calibration song at different times. so i tried calibrating a few more times ending up with the same results. so i unplugged everything. then tried again but calibrated them individually. hmm.. still not working. one last try calibrating all at once and they finally synced up at the same time.

now i tried arming the board and throttle up the motors via remote/tx. and they would all be very VERY off. they didnt start up at the same time. no sync at all from looking at the bar graph on cleanflight throughout the whole throttle range. motor 1 would be at about 1200. 1 and 3 would be about 1500 with a difference of about 50. motor 4 would be about 1300. they even sounded off too. so i cut the throttle andd one motor would keep spinning.... wtf.. remind you that the quad is flat on the table and on cleanflight. it wouldnt stop till i unplugged the battery, because the board wouldnt disarm automatically or manually...thats really weird too. i decided to give it another go. this time the fc wont arm. it would flash green once andd thats it. didnt stay on. eventually it armed after disconnecting everything. gave it 50% throttle. same results. but this time a couple of the motors kept spinning faster and faster. so i cut the throttle. i pick up the quad and the motors twitched and spun depending on how i tilted the board... theres no throttle input and motor_stop is enabled. i then noticed that only the blue led was solid. no red at all. now the blue and red is solid but the green/yellow is now flashing and sputters a bit no matter what. wont arm. i took the fc off the quad. same thing while plugged in via usb.

i dont know whats going on, from such a little crash. its extremely frustrating. ive even tried rebooting the board after all that with the same results. and i dont have much money to spare for this at all so i dont want to buy new parts hoping it would fix the problem when it could be something else. have any of you guys experienced this before or have any idea what may be causing all this to happen?
 
Last edited: