• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Newbie Needing Some Serious Help - MOTORS WON'T SYNC

Dusty

Junior Member
#1
:applause:Hey All,

So i'm a complete newbie to this site and the whole quadcopter hobby, it's been quite the experience so far!!. After tons of research and Youtube Videos I thought I could build my very first FPV250 quadcopter without any hassles - but of course nothing goes smoothly ;). After blowing two PDB boards (Now without the board) and having multiple power issues with my quad it's finallyrunning. The problem I'm having now is I can't get the Motors in SYNC. :confused::confused:

I've calibrated the ESC's multiple times by plugging them each into the receiver, throttle stick full and then back to Zero. While waiting for the beeps. When they plugged directly into the receiever all the motors start spinning straight as soon as I give some power on the remote. But it seems as soon as I have the ESC's plugged into the flight controller it goes out of sync. Generally I can get two of the motors running in SYNC while plugged into the flight controller and then I have to give more power and then the 3rd motor will start and then after even more power the 4th. And then sometimes when I turn the radio off the quad motors spin randomly.

I'm using Openpilot to conifigure the quadcopter, here's my setup:

Frame: Diatone FPV250
Flight Controller: CC3D atom
Motors: 4 x 2300Kv DYS
ESC: 4 x ZTW Spider 12A Opto ESC
Batteries: 1 x 7.3V 1100Mah (For Reciever) + 1 x 11.1V 1300Mah (MAIN)
Receiver : JR R700 7 Channel
Radio: JRpro x2610

Please any suggestions would be appreciated, please let me know if you need any further information.
 

Attachments

pressalltheknobs

Posted a thousand or more times
#3
Probably just configuration.

Motors spinning after the TX is turned off is probably some default failsafe kicking in. You need to configure that. There are failsafes in the ESCs, the RX and the FC. You need to understand those and get it configured before you fly...but first things first.

Spinning "randomly" once you arm it is probably due to the flight mode you have configured. To start with you want it to be as direct as possible so the Flight controller is not trying to level the craft. You need to be in acro ( "sticks", "rates") mode not horizon or angle or some other auto mode. I'm not familiar with cc3d or OpenPilot so I don't know what it's called there. Get your ESCs and accelerometers calibrated and do your first testing and tuning in acro.