• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Transmitter issues with FC

#1
So I’m building my first drone Technically. I’ve helped people build drones before. I just got the Naze32 today and wired everything up correctly with no bridges. So I’m getting signal from my transmitter on my laptop through Cleanflight and I can spin the motors up with the slider bar and calibrated the ESCs. Then I went into the receiver tab and and armed the drone then pushed my throttle up and nothing. So I went to CLI and checked the status and nothing wasn’t not letting me arm so I went back and still nothing. But when I arm it it shows that I’m moving the throttle in the configurator. Idk what to do, I’m in a bind.
 

ElectriSean

Eternal Student
Mentor
#2
But when I arm it it shows that I’m moving the throttle in the configurator. Idk what to do, I’m in a bind.
Not sure what you mean by that... The throttle channel is moving with the arm switch, and without throttle stick input? If that's the case, there's something funky in your Tx mixer settings. If it just won't arm, see below:

 
#3
What I’m saying is when I arm it, the throttle shows in the configuration when I move the throttle stick. But won’t spin the motors
 

ElectriSean

Eternal Student
Mentor
#4
Unless you have MOTOR_STOP enabled, the motors will start spinning as soon as you arm it. If they aren't spinning, it's not arming. If it's not arming, the reason is covered in the video above :) Not sure what version of CF you're running, but newer versions won't arm when connected via USB unless you check the "Props are removed" option in the motors tab.
 
#5
Ok I figured out what is happening. The min check is too low. I need to know how to change it in the configuration because I have a DXe and I can’t change the min throttle input
 

ElectriSean

Eternal Student
Mentor
#6
From the receiver tab, determine what the lowest value you can get on the throttle channel and add 10

In the CLI, type the following

set min_check xxxx
save

xxxx is the number you get in step 1.
 
#9
Ok I got it to work but two of the motors would rev up unless I gave different throttle input. Then I tried to calibrate the ESCs and they didn’t beep so I went in normally just to see if it would change anything and they just started beeping when I gave throttle
 

ElectriSean

Eternal Student
Mentor
#10
Ok I got it to work but two of the motors would rev up unless I gave different throttle input. Then I tried to calibrate the ESCs and they didn’t beep so I went in normally just to see if it would change anything and they just started beeping when I gave throttle
Steady beeping indicates the ESC isn't getting a valid throttle signal. This was probably caused by the calibration failure. Once you get them recalibrated, go to the motors tab and spin up each motor individually, slowly increasing from zero. Make a note of what number each motor starts spinning steadily. Take the highest number and add 10 and set your min_throttle to this number. This should get them all spinning when armed.
 
#11
Ok so they won’t go into calibration mode. Idk why. The other three work fine. One of them beeps and doesn’t spin up. Everything else is great. But they rev up by themselves
 

ElectriSean

Eternal Student
Mentor
#12
The motors revving up by themselves on the bench with props off is normal, it's the FC trying to adjust it's attitude and failing because there are no props. I'm not sure what's up with your ESC's. What kind are they?