• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

blheli gremlin esc issues

#1
I am in a bit of a pickle..

Built my gremlin, and had gotten threw all the way to the motor reversal step in blheli. Up to this point I have had no connection issue, motors spun up fine in betaflight.

Now in blheli, it is having weird communication issues as at first, none of the esc's showed up when read. After cycling the power when connected, it recognizes 2 but they are labeled as "erased or unknown firmware". Then it fails to flash as soon as you try to correct.

blheliescs.png
blheli.png

even more internet searches that lead to nothing. Plugged in again, now 3 esc's are recognized, but with the same problem. On a whim I tried using the chrome blheli app. It can actually read the software on 3 while the 4th is still MIA. Flashing fails on chrome as well.

chromeblheli.png

I am at a loss. I was extremely careful with all soldering. Everything was checked with the multimeter before power applied.

Any help would be great!
 

PsyBorg

Wake up! Time to fly!
Mentor
#2
The stock esc's on the Gremlins need to as you figured out be accessed with the app not the suite.

Several things I would try (going on very limited information about the build) I see the second esc has a min throttle of over 1100. that is well above any safety lock outs and could be the issue for some or all of the problems. I would first try a throttle calibration thru betaflight.

Then if things do not progress I would check what protocol you are using. The Femto I had did not want to run Dshot without either remapping or moving the wire to a pad under the board instead of the normal esc pad. Several others early on reported that it worked the opposite for them that they could run Dshot but not Multishot. I run multi shot as it is faster then Dshot 300 these escs are rated at.

What ever you have yours set to try the other. For general information any rev XX.0 is for one shot, any XX.5 is for multishot only. I am not sure however after 16.5 as thats what I run using multishot and it works great for me. Seeing yours are flashed to 16.5 I would start by setting multishot as the protocol and doing a throttle calibration. If you still have issues come back with any more information you learn when trying these things and we can go from there.
 

PsyBorg

Wake up! Time to fly!
Mentor
#4
SWEET!!! Now you have to get us some pics n vids so the forum can be powered up for the next guys issues!. Welcome to the world of the flying.