• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DX6 Receive Problems

#1
So I just upgraded my old DX6 to the newer model. And I hooked it up to the nano qx, it works great with that. But after I bound it to the receiver it came with, the light comes on that it is bound to a transmitter and it is getting power but when I hook it up to my plane none of the servos or motor power. any suggestions would be great. Thanks.
 

Maingear

Flugzeug Liebhaber
#6
1. I have two dx6 radios. There is a software update that takes 15 min to download. Be sure the radio is finished uploading before powering down.
2. Next goto menu, servo setup, travel, Thr, make it 125% Some esc throws are lower than the spectrum 100% default, especially if they "learn" on the fly and like WOT(wide open throttle) then zero throttle before arming alert.
3. Goto menu, system setup, channel assignments and ensure RX ports have proper config.

Justin
 

Maingear

Flugzeug Liebhaber
#8
Take an sd card inset into the slot in the bottom of your radio goto menu, system setup, system settings, next, next, at the serial number screen export. Serial number will be written to sd card

Insert sd card into computer at spektrum website create an account and it will ask for SD, there is an option to upload serial number. After finished, log in and download updated to sd. Check if the update file is to be in a folder and not just sitting in the sd drive by itself, that is the only thing that is not obvious. That may be fixed when it is updated, who knows?

Reinsert into radio menu, system setup, transfer sd card, option: update firmware, select DX6 Update. Orange bars will flash for a long time.

Voices can be updated the same way.

Setting up a new account is the only pain in the neck. I hate passwords!

There is also an option to download dozens of aircraft model setups. E-flight and blade products are listed. Will be surprised if the nano is not there. I share files at the field. Very cool to load the model settings, then bind and have everything set up. Always verify during preflight what the controls are doing because there may be a rate switch active.

**To clarify above post, takes 15 min for radio to read sd, write to radio, then install update.

Justin
 
Last edited:

Maingear

Flugzeug Liebhaber
#9
I forgot to cover normal condition, both nano and factory Rx have been bound to your tx and no one elses.
Menu, system setup, select model, back button, then radio is in tx mode. It will not tx untill the menu is backed out of system setup and orange light is on (transmitting).
 
#11
Updated the firmware and nothing changed. Using the same electronics I hooked it all back up to my old DX6 to see if it was my battery or ESC but it all worked fine with my old radio. I dont think it is bound right to the receiver or something, and I cant find a way to unbind and try again.
 

ruud

Senior Member
#12
Is your old radio a DX6 or a DX6i? The old DX6 uses a protocol that's not compatible with current DSM2/DSMX radios like the new DX6 (or DX6i, DX9, etc.)
 

Maingear

Flugzeug Liebhaber
#13
Not to be captain obvious, but are you using the bind plug to put the rx in bind mode, the removing after?

I bought 2 more 4 channel and 1 additional 6 channel spectrum RX. I didn't want to bother with changing the settings between models when I use the same Rx over multiple airframes. I have had issues binding before, it seems that the bind button on top worked better than the menu scroll button. No idea why it wouldn't bind, but after a few attempts it worked. One day I'll get around to reading the manual.

Hope you get it figured out,
Justin
 

Maingear

Flugzeug Liebhaber
#15
Did not know I could be too close! I am usually within 4 inches when I bind. Will try backing away.

On page 10 Binding with Receiver and ESC, it says to turn off TX, plug in esc to throttle port on RX, connect battery to ESC, press and hold bind button, then power on the TX, release bind button after RX stops flashing.

P.S. - Don't tell anyone I read the book, I have a reputation to uphold here!

Justin
 

jw423

Junior Member
#16
Just another thought. I have a dx8 and when I go into the setup portion the radio stops transmitting. It warns me though. Any chance it's something like that?
 
#17
Thank You

Thanks maingear for this info, I went through this process last night when my DX6 wouldn't bind to a Lemon RX reciever. Weird thing is that it bound to all my UMX BNF stuff, but would not bind to a regular receiver. Anyway, I got it fixed now, and am looking for a 2S LiPo battery. www.valuehobby.com has a perfect one, but they are sold out. I guess I'll have to wait for that one.

I am a little frustrated that I had to upload new firmware to the DX6 out of the box, and that it comes with AA batteries. I love it's double antennae and other features, but the firmware thing and the battery are a little annoying. I am a convert from a Turnigy 9XR with an Orange Rx module. The Module was starting to lose signal randomly, so I knew it was time to get a nice transmitter with a big model memory, and this thing fit the bill.