• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Esc Problem - No Power???!?!

#1
Hey guys!

So the other day my ESC came to a very hot and sputtering stop. So I decided to get a new Plush 30A ESC to replace it. After much foam carving to get at my bixler's connections, I finally replaced the ESC. I plugged it into the receiver and into the motor to give it a test. However, after plugging in my battery, I immediately noticed that there was no beeps. I gave a bit of throttle... nothing. I checked for a red light on the receiver... nothing. I then plugged my old ESC back into everything and tried it and it worked. Plugged new ESC in... nothing.

I opened up the heat shrink to look at the solder joints for the battery connector. Everything seemed fine. There is a picture below.

Is my ESC dead??? Can I fix this???

Thanks for your help!
 

Attachments

RAM

Posted a thousand or more times
#2
I'm not sure this is correct but I remember something about plugging in at full throttle first then backing it off to zero throttle to set the esc
 

BridgeInspector

Flite Test Groupie
#3
Check to make sure you are getting power to the board from your battery leads. Could be the xt60 plug/ solder.
Should power receiver even if throttle end points are not set.