• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

First Build Help -Tricopter

PsyBorg

Wake up! Time to fly!
#2
Did you select the correct channel count in the Taranis. I know that D-8 and D-16 thing is usually what throws people off with new Taranis gear.
 

CrashRecovery

I'm a care bear...Really?
Mentor
#4
OK do this, remove the kk2. With just the esc, plug in the battery to it. Now you need to press and hold the button on the receiver to put it in bind mode. Now put the servo wire into the reciever The rx should have red and green lights on. You now need to turn on your radio, get into the menu screen and where it says bind you need to hit enter and your radio should start beeping. The RX should then start flashing. Press the enter on your radio, unplug the battery and then restart your radio. Once that is done you should see a steady light on the rx when you plug in the battery.
 
Last edited:
#6
OK do this, remove the kk2. With just the esc, plug in the battery to it. Now you need to press and hold the button on the receiver to put it in bind mode. Now put the servo wire into the reciever The rx should have red and green lights on. You now need to turn on your radio, get into the menu screen and where it says bind you need to hit enter and your radio should start beeping. The RX should then start flashing. Press the enter on your radio, unplug the battery and then restart your radio. Once that is done you should see a steady light on the rx when you plug in the battery.

Just tried this, and then again following the video exactly, and still nothing from the X8R... maybe it could be my soldering (accidentally purchased male to female servo wires, so cut and joined males end to end), so I've ordered some more male to male servo wires, if not could it be that I've got a dead X8R?