• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Frsky Gremlin Betaflight Issue

#1
Hello benevolent Forum Members!

I just got finished soldering up an FT Gremlin, but would someone please help me out with the Betaflight setup? It's being uncooperative...

I'm using a Frsky XM receiver, so when I configure the receiver in Betaflight, I choose 'Serial Based Receiver' and 'SBUS' before clicking 'Save and Reboot.' However, when I come back to this tab after disconnecting and reconnecting, I find that the setting has been reset to 'Spectrum 1024' instead of SBUS.

Naturally, the receiver tab shows no colored bars since the FC is set for the wrong protocol. But here's where it gets weird: If I look at the Receivers tab first, and then go back to the Configuration tab, the protocol shows up as SBUS, like its supposed to, although I still don't see any colored bars on the Receivers tab.

So I guess this is the issue: I can't get SBUS to stick! :) I'm using a Taranis QX7, if that helps, running Betaflight 3.2.1 (and I tried 3.1.3) on Windows 10.

Also, I'm pretty new to the actual building aspect - my soldering is pretty bad, but I don't think that's the issue as the board boots up ok.

Thanks!


PenguinWings
_
 

Craftydan

Hostage Taker of Quads
Staff member
Moderator
Mentor
#2
Hey PenguinWings,

You've probably missed a step. Go back to the ports tab and confirm that one of the UARTs have been set to serial Rx -- I'm not sure which UART to use for what solder points for that board, but until that's set, the serial rx settings on the configuration page won't stick.
 
#3
Thanks for the reply! I just tried enabling Serial Rx on UART 1, 2, and 3.

2 and 3 didn't seem to get SBUS to stick, and UART 1 wouldn't even keep it's Serial Rx switch on... Could it have something to do with the "Configuration/MSP" switch? I've heard one of those connections refers to the USB connection, so I don't want to disable the wrong one! :) Here's a screenshot.

Screenshot (2).png
 

Craftydan

Hostage Taker of Quads
Staff member
Moderator
Mentor
#4
USB VCP is your connection out to USB -- on older F1 boards USB came out UART1, but now that the F3+ boards take advantage of the built-in USB, that port functions without sharing (yeah, leave it alone).

Telemetry and some peripherals can run in parallel to MCP, Serial RX cannot. Again, not sure what is hooked up where on this board, but turn MCP on UART1 off -- you don't need it.

Hmmm . . . looked online and there's a dirth of data for this board :p Still, looks like the three pins opposite the USB plug run the RX for UART3 . . . not that that helps you.

Now the other symptom that strikes me as odd . . . no bars. I've had plenty of mis-configured (and disconnected, and off) receivers, and they always settle to defaults -- 1500 for directions, 1000 for throttle. No bars (or 0) is odd . . . but you're not the first person I've worked with having this problem (and not surprisingly, it was on another Femto board trying to talk SBUS). Unfortunately that issue was not resolved . . . not that that helps you either . . .

So . . . let's take a step back. Have you flashed the latest to this board? I think that's next. You'll need to short the boot pads, connect the USB, then likely load up Zadig to connect the right driver.

I'm betting on the low-odds chance that EMAX flashed it with a betaflight version that's close enough the configurator doesn't revert to CLI mode, but not new enough the configurator handles it properly.
 
#5
Hah! That fixed it! I had tried flashing the firmware before, but I couldn't get it to load in DFU mode, so I gave up. It turned out I needed to read the instructions on Betaflight which said to change some settings with Zadig, like you said... Worked like a charm. Thanks for the help!

Now, the quad graphic goes haywire when I have my Tx bound. In fact, it has the throttle on the right stick... In the build video, TJ switched the 'Channel Map' to Spekctrum/Graupner/JR. My Tx is a Taranis, but this channel map seems to have worked anyway, except for my Aux switches. Is there a different way I'm supposed to do it?

Again, thank you for your help!
 

Craftydan

Hostage Taker of Quads
Staff member
Moderator
Mentor
#6
Nope. you can change in the Taranis whether the default order is TAER or ATER (ATER is the default default IIRC), so some radios need the change in the configurator, some don't. So long as they map correctly, that's all that matters. In the end, the mapping on the "Mix" page in the radio tells you what order things ship out in.

Once that's straight, you need to go into the output page on the radio and set the limits and midpoints for each channel so that the radio tab in the configurator reads from 1000 to 2000 for the stick throw and centers on 1500 -- BTW, midpoint tends to drift off 1500 while adjusting the limits, so do it last. then your poor quad graphic should settle down. If it doesn't stop (your midpoint jitters a bit around 1500) move the deadband up a few points to get the graphic to stop . . . and your flight channels are setup :)

If you're missing (or want more) aux channels for modes and such, they get assigned to something on the mix page (you can create switch/slider inputs on the input page then map them on mix, or just create an input line directly in mix page). By default you the first 8 mixes are automatically piped out to the RX. If the RX can do more, you bump up the channel #'s outputed in the configuration tab under the internal transmitter section at the bottom.

Sounds like you're well on your way :)
 
Last edited:
#10
help me!!!!!!

USB VCP is your connection out to USB -- on older F1 boards USB came out UART1, but now that the F3+ boards take advantage of the built-in USB, that port functions without sharing (yeah, leave it alone).

Telemetry and some peripherals can run in parallel to MCP, Serial RX cannot. Again, not sure what is hooked up where on this board, but turn MCP on UART1 off -- you don't need it.

Hmmm . . . looked online and there's a dirth of data for this board :p Still, looks like the three pins opposite the USB plug run the RX for UART3 . . . not that that helps you.

Now the other symptom that strikes me as odd . . . no bars. I've had plenty of mis-configured (and disconnected, and off) receivers, and they always settle to defaults -- 1500 for directions, 1000 for throttle. No bars (or 0) is odd . . . but you're not the first person I've worked with having this problem (and not surprisingly, it was on another Femto board trying to talk SBUS). Unfortunately that issue was not resolved . . . not that that helps you either . . .



So . . . let's take a step back. Have you flashed the latest to this board? I think that's next. You'll need to short the boot pads, connect the USB, then likely load up Zadig to connect the right driver.

I'm betting on the low-odds chance that EMAX flashed it with a betaflight version that's close enough the configurator doesn't revert to CLI mode, but not new enough the configurator handles it properly.
hi
so i have the same problem as him but i tried to flash the new betaflight software but it wont flash Screenshot (34).png