• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Issue with motors not spinning up

#1
I recently got out my Mini Tricopter from RC Explorer to get that working again. I am using Cleanflight for setup on a Naze32. After installing the new firmware (Triflight 0.7) I went through the steps which I had done several times before. This time when I got to plugging in the battery I noticed that the servo on the tail did not center. I went to the motors tab and tried spinning up the motors but nothing happened.
I thought that maybe the motors weren't getting power so I check the ESCs with a multimeter, but they all got normal voltage. Also the motors all twitch and make a tone when the battery is plugged in. They do not make the tone that signals that they are armed. The servo also gets power when I turn ESC/Motor protocol to PWM, for whatever reason. I check the wiring and it is all working as normal. The everything works fine on the receiver tab. I setup the modes and the board itself does arm when I tell it to (green and blue lights).
I can't think of anything else to try, so any ideas would be appreciated.
 

cranialrectosis

Faster than a speeding faceplant!
Mentor
#2
I had to go to BetaFlight after the new updates for Cleanflight earlier this year. I was not able to get Triflight working on the latest Cleanflight.

I hear Betaflight won't support the Naze32 (F1 boards) for too much longer. Have you considered an F3FC Racing from RC Explorer? I run this set up on my Twitchity mini tricopter and I LOVE it! For this reason I am considering upgrading my WarpQuad String Theory to a Lux.
 
#3
I just tried programming the copter in Betaflight. Same issue, the motors won't spin up. As for the F3FC board, I'd like to get my current board running again so I can invest in a Baby Tricopter soon.
 

cranialrectosis

Faster than a speeding faceplant!
Mentor
#4
I had trouble where my ESCs were not getting the proper low and high throttle signals. When I connected, the ESCs wouldn't chime what I expected and were telling me what was wrong.

Are you aware of the odd wiring for a Naze32 for tricopters?

If this is a Naze rev 6 are you powering the Naze from the BEC of an ESC?

What ESCs are you using and what firmware are they running?
 
#5
The tricopter has worked fine in the past and nothing has changed since. I have the old RC Explorer power pack with BE2208 1800kv motors, and 30A Favourite Little Bee ESCs. I also have the original frame, so the bottom is a PDB that powers the top plate which has an integrated Naze32 board. So I know my wiring is correct and that everything gets the correct voltage.