• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! New Sport Cub S - bind light won’t blink / binding won’t initiate

#1
Hello all,

I’m on my second sport cub s and out of the box the bind light won’t come on/blink to initiate binding. It flashes once when I put the battery in but won’t blink like it’s supposed to when set on a level surface. I read in another forum to elevate the tail wheel on a magazine or book when plugging the battery in but that didn’t work either. Put the same battery back in my old cub and the bind light flashes like it is supposed to prior to binding. The new one won’t do anything except blank once when plugging the battery in.

Any help or ideas to try are appreciated. I will call horizon hobby when they open tomorrow as well. Nothing in the manual/troubleshooting guide addresses this situation.

Thanks!
 
#3
It might already be bound. Maybe try turning on the transmitter and plane and try to move the controls.
Thanks Ketchup. This is the BNF version and I am using the remote from my original RTF sport cub s. With that said, I still tried to get the plane to respond to the remote and nothing happens. Even when I try the bind process. I don’t think the plane is entering bind mode.

Thanks again
 
#5
Yes it has a bind mode but that wasn’t working. I tried the idea of removing all the connectors while powered up and then unplugging power and then everything back in. It worked. Well sorta. Now all the controls shake violently. Good new is HobbyZone sent me a new receiver and the plane is in the air. Thanks for the help ketchup.