• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Newbie ESC/Motor

daddoesntknowall

Newbie foamboard builder
#1
The good news.

We built a foam board plane (thank you Flite Test)

RC kit we have.
A DX9 Tx (we wanted future options)
Spektrum AR610 receiver with remote recevier (belt and braces)
Suppo 50A ESC (I figured >A means harder to kill) with BEC
a Suppo brushless motor 2814/8. 1000Kv I believe.
3Cell 11.2v Lipo, a couple of those
iMAXB6AC charger.
A bunch of 9g servos.
10x7 prop

All WAS good. Bench tested some weeks ago the tx/rx/battery/servos/esc/motor. It literally all just worked out of the box. Watched youtube vids for several hours,. bought the stuff, plugged it in. And everything worked.

Build plane, install stuff in plane.

Servos all work. No motor. Hmm..

Much googling and youtube later, discover how to reset throttle range on ESC and put it in auto LIPO detect etc.

Sadly, we're now at this point.

Every time I "reset" the ESC, that is, switch on tx, throttle up, connect battery wait for beeps, throttle down wait for ready beeps, I can then throttle up and as it gets to 25% the motor spins. It spins and sounds normal, nothing nasty, no heat, no weird noise, for maybe a second or so then shuts down.

Now it doesn't run.

Turn all off and on. Still doesn't run.

Go through the ESC reset described above and it briefly works again.

So, i'm thinking now that maybe motor is pulling too much current perhaps (based on stuff I've read) but don't know how to properly measure that and in any event the 50A ESC would seem to be more than capable of delivering whatever that motor needs. (I have the prop off while trying to get motor to run of course)

Or maybe the battery not up to the job (I have two, voltage is good, all balanced, both fully charged)

Whether the motor works or not all servos continue.

I thought maybe some throttle cutout on the DX9 so reset the model config, ensured nothing fancy is enabled.

I'm all out of ideas and am at the point where I'm just about to buy a matched battery/ESC/Motor combo from flittest or another so I have something else to test against.

All suggestions for next steps most welcome!

Many thanks
 
#2
make sure you plug the motor into the throttle channel and not the bind plug, i had similar odd behaviour until i realised i wasnt in the right port.

failing that i dont know.
 

daddoesntknowall

Newbie foamboard builder
#4
I should probably also say that esc to motor connections are good (removed heatshrink on bullet connectors and tested continuity either side of connection) and also resistance between each pair among the three motor wires is as it should be according to some other suggestions I found on the web for motor problems.
 

Hai-Lee

Old and Bold RC PILOT
#5
You do not mention the battery capacity! When running a large ESC on a small capacity battery the idle.bias current of the ESC itself can become less than insignificant. It does combine with the motor current draw to give total battery current. There is a small possibility that the total current is causing the battery voltage to sag significantly and the LVC operation of the ESC to be triggered thereby cutting the throttle to the motor. As the bias current is a continuous draw the battery may not recover sufficiently to re-enable the motor circuit especially if the battery connectors are small or poor quality.

I would suggest that you attempt to change the LVC setting to "reduce throttle" and try different timing settings for the ESC as a low current motor may actually causing it to become sort of confused.

Just a few thoughts,

have fun!
 

daddoesntknowall

Newbie foamboard builder
#6
Thank you. The battery is a Flureon Lipo 3 cell 30C 3000maH. I have a small voltage checker do-da that alarms if any cell goes below 3v. I suspect it's probably not fast enough response/display to catch a voltage dip anyway but it's not showing anything obvious. I'll try the ESC programming you suggest. thank you.
 

daddoesntknowall

Newbie foamboard builder
#8
That was my assumption. Since we didn't realise the ESC was even programmable before we started playing around I've assumed that I've reprogrammed it accidentally. I have the manual from the link above (thank you) and have reset (painfully, it does go on!) every option.

Bearing in mind comment above re LCV I tried 2 cell with a lower cutoff voltage. No difference from the expected 3 cell setting.
Every option in the throttle (Auto, 1.1-1.8ms, Hard Acc, Soft Acc) still 'works' as described in my intro.
PWM timing seems to manage to fire it up regardless of the settings.

At some point I'm going to want or need another motor, ESC and battery. So, perhaps someone could point me too a matched set of battery, esc (with BEC) and motor? If I can have that work reliably I can then eliminate one component at a time?

Might a video help spur ideas?

Thanks everyone
 

TazRC

Obsession, not hobby
#9
After I posted the link I was looking at some of the instruction sheets and it looks like most are defaulted to NiMH battery type..? Recently I had a similar problem with a Castle ESC being set to Auto Throttle with a particular motor. I set it to Manual and did the calibration and that worked. Might be worth a try on yours if you haven't already tried that.