• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Please help with my quadrotor - motors do not spin in sync

jc17

Junior Member
#1
I haven't found any cases or solutions for this that worked for me on the Internet yet so hopefully we can solve this for anyone else that might be having this problem.

I’ve been building a quadcopter and the motors do not spin at the same time when I increase the throttle.

I’m using a KK 2.1.5 board with default firmware. I’m using Turnigy AE-30A brushless ESCs from HobbyKing.

I have my quadcopter in a + configuration, where I would consider motor 1 to be at 12 o’clock, motor 2 at 3 o’ clock, motor 3 at 6 o’ clock and motor 4 at 9 o’ clock.

When I increase throttle, motors 1 and 3 start spinning at nearly the same time (when I am 3 or 4 notches above zero throttle, respectively). SEVERAL notches of throttle later, motors 2 and 4 start to go, also at different times than each other (I’m talking around 12 notches later than motors 1 and 3, a pretty significant difference).

I don’t believe it’s a problem of the ESCs or motors because when I try to plug ANY of the ESCs into the M1 output of the KK board (the very top-right set of 3 pins you plug the white/red/black wires from the ESC into), the motor will always spin given the same amount of throttle – about 3 notches above zero throttle.

I have calibrated by ESCs several times, both simultaneously and one-by-one. I tried calibrating with and without trims and got the same failed result. My Turnigy programming card does not seem to be compatible with these ESCs. The process I followed was:
1. Put throttle on tx to maximum
2. Turned tx on
3. Held down KK board buttons 1 and 4
4. Powered KK board with lipo battery and entered throttle pass-through mode
5. Brought throttle to zero and heard confirmation tone (I know my throttle channel is not reversed)
6. Set each ESC’s settings (Turnigy AE-30a)
7. After setup, unplugged battery

Then I would arm the KK board, increase throttle and see that the motors are all out of sync.

I understand that with the KK board you’re supposed to turn it on with your tx at max throttle, wait for a confirmation tone, then turn the throttle back down to zero to calibrate the throttle end points. However, this ESC Turnigy AE-30a enters programming mode when you turn it on with max throttle on the tx! How else can you calibrate throttle end points with the KK 2.1.5?

I’ve documented the parts I’ve used, my building process up to now, and just about anything else you might want to know about my troubleshooting attempts. If you have any questions that might help with figuring out this issue, don’t hesitate to ask and I’ll spill whatever you need.

Thanks so much for any help!
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#2
Jc,

First off, welcome to the forum!

two things . . . one that will fix this problem and another that might just make the board behave better overall:

1 - go into the misc settigns menu and bump up the "minimum throttle" setting by a few points, test and repeat until they all start simultanouosly. this is an "inhibit" from the board, so that if your throttle stick is bleow this, they all get 0, above that they all get at least that. not only will it stat everyone at a good idle speed, the contorl logic can't "correct" any one motor below that, casuing the ESC to shut down in flight (if the ESC goes below "off", it stops . . . and can take a while to spin up again).

2 - if you haven't, reflash. stock roms on the kk2's are good enough to make sure everything works, but they're riddled with bugs -- I don't trust it. Do yourself a favor and reflash it to either Steveis's or RC911's latest ROMs, they've cleaned out most of the bugs 9all of the nasty ones) and added a few nice features. If you need help with that process, we can get you pointed in the right direction.
 
#3
Hey jc17,

I just set up my first Fliittest H quadcopter about 3 weeks ago! I am not an expert but I got the thing flying successfully!

I also used the default software in the Hobbyking 2.1.5 board, but I used the default settings that Mesa Foam Fighters gives in their KK setup video and they worked great. I am using the HK plush 25 AMP ESCs with stock software as well. I have the HK DT750 motors but I do not like the mounts, other then that motors are great.

So here are some things to try;

1. I believe you should be using the " X " setting, not " + "
2. Make sure you have your motors (ESC) connection to the board in correct order. I did not have them correct the first time and my quad just flipped over on its back and ruined two props.
3. The HK 2.1.5 board I have does not have an ESC setup. You need to make sure you set full throttle (with no props) and attach battery--that should set your max travel on the ESC. Also you want your throttle setting on the KK board set to 20. After I set mine to 20 that fixed one slow motor start I had. See the Mesa FF setup video on you tube. ( I never pressed buttons 1 & 4 because it was not in the instructions and there was no ESC calibration in my menu)
4. I never powered up my quad with props on it with throttle at full--- should be done once before you put props on. All further powerups are at idle and then arm board by taking rudder to full right. If all else fails order the red, HK Plush 25 AMP ESCs ---(assuming your set up can use them--they also come in 30 AMP)

Let me know if this helps!
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#4
3. The HK 2.1.5 board I have does not have an ESC setup. You need to make sure you set full throttle (with no props) and attach battery--that should set your max travel on the ESC. Also you want your throttle setting on the KK board set to 20. After I set mine to 20 that fixed one slow motor start I had. See the Mesa FF setup video on you tube. ( I never pressed buttons 1 & 4 because it was not in the instructions and there was no ESC calibration in my menu)
Your board does have an onboard ESC calibration sequence, and that is it as described -- with the props off, hold button 1&4 as you power up (with thottle on high), and after the ESC's chime that they're ready, reduce throttle to minimum.

Durring this process, the screen will state that it's a pass though, but in fact it is not. the ESC's get passed a fixed long pulsewidth when the "pass through" throttle is above a midpoint, and , and a fixed short pulsewidth when below. there are even ROM versions that have this as a menu item, with significant lockouts to remind the user to remove the props first.

This is important becasue at any point in time, the pulsewidths comming out of your RX are *not* the pulsewidths going out to your ESC, but a re-calculated width including corrections, mixing and stick scaling. Calibrate *through* the kk2 board -- it's a subtle but real difference.

As for your ROM, I HIGHLY recommend reflashign your kk2 board. the hardware is nice, but the stock roms are garbage -- buggy, but enough to test the hardware. look into flashing Steveis's or RC911's latest ROMs. it'll make a tremendous improvment in how well it flies.

BTW, Welcome to the forum!
 
#5
Yeah I never pushed buttons 1 and 4. I saw a video on youtube and they just left the throttle at full (props off). So are you saying my ESCs are not calibrated because it is all working fine. They all spin together with no issues.
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#6
The are calibrated to your RX, not your kk2.

I'm not saying they won't work. I'm saying it's one tuning step you've skipped. Of all the steps it's not a huge impact but it's there.

I'm also saying if you haven't flashed the ROM . . . you're missing out in a lot nicer flying ;)
 

jc17

Junior Member
#7
Jc,

First off, welcome to the forum!

two things . . . one that will fix this problem and another that might just make the board behave better overall:

1 - go into the misc settigns menu and bump up the "minimum throttle" setting by a few points, test and repeat until they all start simultanouosly. this is an "inhibit" from the board, so that if your throttle stick is bleow this, they all get 0, above that they all get at least that. not only will it stat everyone at a good idle speed, the contorl logic can't "correct" any one motor below that, casuing the ESC to shut down in flight (if the ESC goes below "off", it stops . . . and can take a while to spin up again).

2 - if you haven't, reflash. stock roms on the kk2's are good enough to make sure everything works, but they're riddled with bugs -- I don't trust it. Do yourself a favor and reflash it to either Steveis's or RC911's latest ROMs, they've cleaned out most of the bugs 9all of the nasty ones) and added a few nice features. If you need help with that process, we can get you pointed in the right direction.
Crafty Dan you are the MAN! Suggestion 1 got my motors to spin up simultaneously once I changed the minimum throttle from 3 to 16 (I incremented until I saw the motors start up at the same time). This worked like a charm, thank you so much!!

In regards to point 2, you definitely seem to know what you're talking about so I will trust you on this. Could you point me in the right direction? Specifically - how can I reflash the KK 2.1.5 with those ROMs? Where can I find these ROMs?

CMS_1961 said:
1. I believe you should be using the " X " setting, not " + "
2. Make sure you have your motors (ESC) connection to the board in correct order. I did not have them correct the first time and my quad just flipped over on its back and ruined two props.
3. The HK 2.1.5 board I have does not have an ESC setup. You need to make sure you set full throttle (with no props) and attach battery--that should set your max travel on the ESC. Also you want your throttle setting on the KK board set to 20. After I set mine to 20 that fixed one slow motor start I had. See the Mesa FF setup video on you tube. ( I never pressed buttons 1 & 4 because it was not in the instructions and there was no ESC calibration in my menu)
4. I never powered up my quad with props on it with throttle at full--- should be done once before you put props on. All further powerups are at idle and then arm board by taking rudder to full right. If all else fails order the red, HK Plush 25 AMP ESCs ---(assuming your set up can use them--they also come in 30 AMP)
Thanks for the reply CMS! I will try changing between X and + modes once I can get my quad in the air at all haha. I will keep that in mind.

My motors' ESC connection are definitely connected to the board in the correct order.

When you say 'you want your throttle setting on the KK board set to 20' what do you mean exactly? The minimum throttle setting from the misc. settings menu item? Craftydan recommended this and it worked like a charm.

I always always keep my props off haha those things deserve respect. Craftydan's solution seemed to work but I'll hang onto your other points in my mind incase anything else pops up. Thanks for your input!
 
#8
I think Craftydan gave you the right info.

My minimum throttle is set to 20 in the misc settings menu. That was what I was trying to tell you. Craftydan explained it better.

As far as the ROMs --- I think I will listen to Craftydan when I know how to fix them. I can tell you I have been flying my FT Quadcopter for the last 3 weeks and have had no issues-- it flys! I can hover, all the flight control inputs are working great. I don't know much about quads though. This is my first one. I mostly fly airplanes--- wings, gliders and some sport planes. Hopefully Craftydan will post some info on how to correct the ROMs. I believe this involves flashing new firmware on the KK board. I also read in other places that SimonK is the hot fix for ESC issues. There is an article here on Flite Test on how to flash an ESC.
 
#9
Craftydan,

BTW thanks for the Welcome!!

Thanks for your help on the KK. It is really confusing for someone new to Quads to figure all this stuff out. The instructions on line at HK for the board are not too good. I used the Mesa Foam Fighters Video about setting up the KK 2.0 board---it worked!! I have been flying with the stock KK 2.1.5 board and HK Plush 25 AMP stock ESCs and the quad is responsive and controllable. I eventually want to use it as an FPV platform.

Any more ideas or suggestions you have to make it better are appreciated.
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#10
JC, glad I could help.

I will try changing between X and + modes once I can get my quad in the air at all haha. I will keep that in mind.
um . . . keep it on the ground until that's right -- if you've picked the wrong one, you're in for a gnarly insta-flip, with a good chance of breaking props.

+ vx. X really depends on how your board is mounted -- if the buttons are alligned to a single rear boom (boom out the left and right, and noe more out the front) you're "+". If the buttons are alligned between two rear booms, (with to other booms going forward and left/right) you're "X". From what you've described in your OP, you're using "+". Get them swapped and the board will get confused with it's corrections and will spin-and-flip on takeoff.


The instructions on line at HK for the board are not too good.
You have a gift for understatement, do you?

Horrid would be my word, but of their selection of products it's better than most :p

I've been really impressed by Steveis's writeup as both a manual and a guide (Guide starts on pp.21, and a bit terse, but he just spent the last 20 pages describing most of the features you'll be setting up). Keep in mind, it describes all of the features of his ROM -- if you don't flash it or flash RC911's AiO instead, there will be discrepencies in what is documented, but the descriptions should be accurate.

you'll find the latest version as an attachment to the first post here:

http://www.rcgroups.com/forums/showthread.php?t=2218254


As for flashing the kk2 you'll need an AVR programmer, like a USBASP, and a software flash tool to flash the binary file down to the board.

HK sells a USBASP connector with the right adapters, but it's a pretty common electronics tool in the hobby market, so you don't have to buy theirs. A search of amazon or ebay (or whatever your region's local online marketplace is) should pop up a few good local-ish suppliers. One word of caution -- the standard connecotr is an 8 pin, but the kk2 usis the less common 6 pin connector. You'll need to build/buy an adapter, but it's not hard to find one bundled with the USBASP.

As for the software flashtool, google "Lazyzero" to get his "Multikoper Flash tool". download and instal it, and once it's running , it can download and flash a wide variety of ROMs for a wide variety of devices, including the kk2's and many ESCs. If you select the kk2.1.x in the menus it should have Steveis's ROM's (1.18S1 is the latest IIRC) or RC911's AiO, either of which should be good ROMs.
 
#11
ESC calibration

Your board does have an onboard ESC calibration sequence, and that is it as described -- with the props off, hold button 1&4 as you power up (with thottle on high), and after the ESC's chime that they're ready, reduce throttle to minimum.

Durring this process, the screen will state that it's a pass though, but in fact it is not. the ESC's get passed a fixed long pulsewidth when the "pass through" throttle is above a midpoint, and , and a fixed short pulsewidth when below. there are even ROM versions that have this as a menu item, with significant lockouts to remind the user to remove the props first.

This is important becasue at any point in time, the pulsewidths comming out of your RX are *not* the pulsewidths going out to your ESC, but a re-calculated width including corrections, mixing and stick scaling. Calibrate *through* the kk2 board -- it's a subtle but real difference.

As for your ROM, I HIGHLY recommend reflashign your kk2 board. the hardware is nice, but the stock roms are garbage -- buggy, but enough to test the hardware. look into flashing Steveis's or RC911's latest ROMs. it'll make a tremendous improvment in how well it flies.

BTW, Welcome to the forum!
New guy here....
This kk2.1.5 board is buggy as hell. If I wasn't so cheap I would buy the jumper and reflash, but I like a challenge. Have been trying to get all 4 motors to start at the same time. First did a factory reset on the board and set everything up as per instructions on many of the internet/yahoo help videos. No mater what I did, or how many times I did it, nothing worked. I convinced myself the motors were bad....switched them around, same thing .. #1 was always the last to spin, #3 was the first, then #2 and #4 would kick in. I performed the esc cal , without kidding, more than 30 times over the period of 6 days. Today I did another factory reset, and adjusted what needed to be adjusted, and BAM, they all started at the same time. I read somewhere that it might take a few trys to get the esc cal to work....they weren't kidding. All is good for now. Lets hope it sticks, I have to unplug everything and remount the board in its permanent location. Thanks all for your info, felt good to see I wasn't alone. Krieg
 

Skillz

Junior Member
#12
Im having the same problem with my eachine falcon 250 pro. I calibrated acceleration in cleanflight now my motors don't spin in sync. Will re-flashing fix the problem