• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

what am I doing wrong.

#1
Hi, i am just putting the electronics into a FT Mighty Mini Arrow.
I have a Spektrum Dx6i (with AR6200) and just got a RS20A 20A BLHELI_S. ESC. I wired it up as I had before (with a much older and chunkier ESC) but now my receiver is not blinking at all. The ESC beeps as I plug a battery in, but the receiver isn't blinking and nor do I have throttle or servo controls. I tried binding the model several times but nothing changed. (I confirmed with the help of a friend that the receiver works (we could plug his esc and motor into it and it worked fine).

What am I doing wrong? Is there a specific way to get the esc started? do i need to flash it?

thanks for all the help,
David
 

Hai-Lee

Old and Bold RC PILOT
#2
It might sound silly but how many wires in the plug from the ESC to the Rx?

I ask because some ESCs do not have a BEC onboard.

Have fun!
 
#3
You are right. It's only got 2. Missing the 5V BEC one. Is there a way for me to work around this or am I better off just purchasing a new ESC that has onboard BEC?

thanks for the quick help,
David
 

Hai-Lee

Old and Bold RC PILOT
#4
Normally either buy a UBEC and fit both to the battery or buy an new ESC with bec. If you wish to kinow it is not a total loss because if you ever build a twin engine you already have one ESC to use.

Sorry!

have fun!