• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! BeeBrain V2 + Spektrum DxE

#1
Hello FliteTest Community,

i have big problems in programming my transmitter or the FC:

DXE: Newest Software update and new model with reversed aileron and rudder channel (in Betaflight i have the right output = the drone moves in the right direction)

BeeBrain V2: Newest Betaflight (apple mac) ONLINE Flash from NewBeeDrone

And now my Problems:

- its not possible to arm the motor, the fc is flashing blue and green, if my transmitter is bind the led is red

Can someone help me, please?

With my inductrix FPV pro, my life was easier...

Greetings from Germany
 

sprzout

Knower of useless information
Mentor
#2
I had similar problems on my ix12, with the Beebrain V2.

When you go into modes, what aux is your ARM set to? is it set to Aux1? If so, you need to identify in your Channel Assign which switch that is programmed to. I have mine programmed to Switch B on my ix12; yours may be configured differently.
 
#3
I had similar problems on my ix12, with the Beebrain V2.

When you go into modes, what aux is your ARM set to? is it set to Aux1? If so, you need to identify in your Channel Assign which switch that is programmed to. I have mine programmed to Switch B on my ix12; yours may be configured differently.
Thank you for your fast answer! I am feeling good in this forum! You have to understand that i am a newbee (noob) i dont understand the programming of my transmitter (do i have the right model selected?). I read something about to trimm or suptrim the trothle to a minimum? I get so confused right now...
 

sprzout

Knower of useless information
Mentor
#4
Thank you for your fast answer! I am feeling good in this forum! You have to understand that i am a newbee (noob) i dont understand the programming of my transmitter (do i have the right model selected?). I read something about to trimm or suptrim the trothle to a minimum? I get so confused right now...
Ok, let me start here:


Have you gone through the Betaflight setup first, as laid out in the YouTube video? I know it says to use Chrome to get the latest Betaflight Configurator, but ignore that - it is an older video, and you now need to use the Betaflight Configurator for the OS instead.

When it gets to ARM, you should have it set to AUX1. On your DxE programming for Channel assignment, there should be an option with AUX1 that you can assign to a switch (i.e., Switch A, Switch B, etc.) You need to set the AUX1 setting to whichever switch you want to use for arming. Once you have done that, save and reboot, disconnect, and plug a battery in. You should then see in your onscreen display, when you first connect, the Betaflight info come up. Flipping the switch to the "Armed" position will then arm your quadcopter.

Also, if you plug a battery in and you have the switch in the "Armed" position, you will need to turn the switch off, wait a few seconds, and then switch it back on, at which point on your onscreen display, it should read "ARMED" and then go back to the rest of the display. That was an issue for me that I didn't discover initially, and I thought I'd gotten a bad board.
 
#5
Ok, let me start here:


Have you gone through the Betaflight setup first, as laid out in the YouTube video? I know it says to use Chrome to get the latest Betaflight Configurator, but ignore that - it is an older video, and you now need to use the Betaflight Configurator for the OS instead.

When it gets to ARM, you should have it set to AUX1. On your DxE programming for Channel assignment, there should be an option with AUX1 that you can assign to a switch (i.e., Switch A, Switch B, etc.) You need to set the AUX1 setting to whichever switch you want to use for arming. Once you have done that, save and reboot, disconnect, and plug a battery in. You should then see in your onscreen display, when you first connect, the Betaflight info come up. Flipping the switch to the "Armed" position will then arm your quadcopter.

Also, if you plug a battery in and you have the switch in the "Armed" position, you will need to turn the switch off, wait a few seconds, and then switch it back on, at which point on your onscreen display, it should read "ARMED" and then go back to the rest of the display. That was an issue for me that I didn't discover initially, and I thought I'd gotten a bad board.
thank you !!! i will give it a try! :)