• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DSM2 Sat Rx No longer listens to input

#1
So i have a micro racing quad, the kingkong 95gt. i LOVE this thing, fly it all the time. However i recently took a pretty hard landing because i hit a branch, probably hit the ground 6 feet from the air. When it came back into the air i had no control input and tried to disarm but it kept going in the last direction it had heard. then a couple seconds later it disarmed itself because it realized there was no transmitter connected. I picked it up and took it inside, and examined the mini DSM2 sat Rx and couldn't see any obvious damage, looks like new. so I tried binding with it again and every time i bound (which the transmitter said was successful everytime) it would go into this medium speed flashing LED infinitely and not listen to the Tx (which is a Spektrum Dxe btw). im hoping that what has happened is the Rx broke somehow, and not anything in the flight stack because its alot cheaper to replace the sat Rx. Any help would be greatly appreciated, thanks!

Quadcopter:

https://www.gearbest.com/brushless-fpv-racer/pp_639633.html

Rx (comes with DSM2 version of this quadcopter):

http://www.ebay.com/itm/Micro-Spectrum-JR-DSM2-DSMX-7-Channel-Satellite-Receiver-For-FPV-Drone-Quadcoper/112495958316?_trkparms=aid%3D111001%26algo%3DREC.SEED%26ao%3D1%26asc%3D20160908105057%26meid%3D733d17187b0044d09164951a6e8d6e3d%26pid%3D100675%26rk%3D4%26rkt%3D15%26sd%3D282405219694&_trksid=p2481888.c100675.m4236&_trkparms=pageci%253A81bb4a9d-929f-11e7-a7ae-74dbd1804bfb%257Cparentrq%253A54b8aedd15e0a860e7ab2672fffff0b1%257Ciid%253A1
 
Last edited:

ElectriSean

Eternal Student
Mentor
#2
Most likely a dead receiver. Can you still connect to the BF configurator? Does the model image still move as you move the copter?