• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Eachine Wizard x220hv arms but motors wont spin

#1
So I was flying it yesterday and everything was alright. I didn't crash it and got some great footage. Anyway, today I took it to a park and tried to fly it. I was surprised when it armed and everything, but the motors didn't spin. I went onto betaflight and all the settings are the same. It says the motors are armed and they are supposed to spin when armed but they don't, even when I raise the throttle they don't do anything.
 

FDS

Well-known member
#2
Have you tried running the motors on just the individual sliders in the motors tab in Betaflight? What ESC do you have?
 
#3
Alright so I got all the motors to spin on the Betaflight motor tab, but when I arm it all but one motor spins. It won't start to spin until half throttle. I have the 45A 4 in 1 BLHeli_S ESC 2-6S
 

FDS

Well-known member
#4
If you raise the all motors slider in Betaflight do all 4 motors move the same speed? Obviously you have the props off.
Do you have the original tune saved? Diff all dump off the CLI and the profile?
 

IanSR

Active member
#5
Sounds like your ESC has taken a dump.
A bad ESC will not usually kill a motor but a bad motor will kill an ESC.

To check it is not a bad motor, take off your offending one ( the one that doesn't spin) and connect it to a known working ESC, if it runs, then that particular ESC it was originally on has died, if it continues the bad behavour, it's probably the motor.

Also look in the can, see if the motor wires are a nice Ginger color, if they're black, the motor has burnt out.

Unfortunately you're gonna need to do some tinkering to find out where this problem is.