• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Graupner MZ12 trouble with binding

#1
Hello all,

Sorry if this has been asked before, kindly point me to the right thread.

I've had a Graupner MZ12 for over a year now, really happy about the radio. I use it with three planes, moving the receiver back and forth. Today when I was going to fly I couldn't get the transmitter to bind with the reciever. I did what I allways do

  • Turn off the RF transmit
  • Select model from the memory
  • Hold the set button on the receiver and when LED goes dark I press the bind button on the transmitter.
  • I can hear the familiar melody when the binding occurs

But my transmitter will not recognize that it is bound to the reciever. RX bind still reads --- and I cannot turn on the RF transmit. If I try to repeat the process I will not get the melody unless I power down the reciever and then power it up again.

I've tried this with two of my planes to rule out any issues with plane electronics. I've even updated the firmware on the transmitter.

Please, any advice is appreciated.

Kind regards,
Eric
 

FlyingMonkey

Stuck in Sunny FL
Staff member
Admin
#2
Make sure the trainer switch is in the far back position. If it's in the middle, or the front, it won't activate the bind.
 
#3
Thank you for your quick reply. My transmitter doesn't have a switch named that but from reference images, I guess it must be the one called S6 on mine. All switches is at the far back position. Still no change.

Is it possible to do a factory reset on the transmitter? (I've backed up all my planes on disc). The only thing I've found is how to reset the receiver.

/Eric