• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Gremlin Receiver Issue in Beta Flight

#1
Hi everyone!

I've been having some issues with my gremlin in Beta Flight. I've followed the video build guide very closely, but when I go into the receiver tab, all of the values are at 0. I'm using the same exact receiver as the one used in the build video, and my transmitter is a DX6i.

Does anyone know how to fix this issue? I can't seem to find anything about it online. Help would be greatly appreciated!

Thanks.
 

PsyBorg

Wake up! Time to fly!
#3
More then likely you have done what several people have and mixed up the uart you have connected to. I believe Sean pointed out that they stated the wrong uart for certain receivers in the build video? Anyway start there and see what that gets you.
 
#5
When setting up my BabyHawk, I ran into the same problem. Ultimately, my problems went away when I flashed Betaflight 3.1.7 on the flight controller.

Prior to flashing 3.1.7 on the flight controller, I confirmed my UART settings. I was able to put the sat receiver into bind mode multiple times through the CLI... This confirmed for me that the FC was able to talk to the receiver. I was able to bind it with my DX6. When I turned off my TX, the status light on the RX would go out. When I turned the TX back on, it would bind again with the RX (signal strength indicator would light up on the DX6 screen) and the status light on the RX would come on. Everything appeared to work, except the receiver tab in BF showed absolutely no activity. I was avoiding flashing new firmware on the FC until I got things working, but when I hit this brick wall, I flashed the firmware, and the problem went away.
 

ElectriSean

Eternal Student
Mentor
#6
I'm pretty sure this issue is a conflict between certain versions of the firmware and the configurator. It should go away with any of the 3.2 firmwares and the newer configurator.
 
#9
If you haven't done so already, I would suggest you check out Joshua Bardwell's videos on YouTube. He has a series on setting up Betaflight, including troubleshooting connection issues.
 

FlyingMonkey

Stuck in Sunny FL
Staff member
Admin
#15
I hate to say "have you tried turning it off and on again" but...

In doing a google search for this exact set of symptoms, it seems that one possible solution, is to reflash betaflight to the board.
 

TazRC

Obsession, not hobby
#16
FlyingMonkey might have it. I see your FC is on 3.0.1 and Betaflight Configurator is probably 3.2.2. I recall some folks having issues with FC versions older than 3.1.6 or 3.1.7 with 3.2 and new Configurator.
 
#17
That’s what I’ve kind of figured out. The problem is, I can’t get the board to flash. I’ve watched several videos on how to do it, but I always get the “Failed to contact boot loader, programming failed”.
 

PsyBorg

Wake up! Time to fly!
#18
If you can not connect thru the bootloader then that's a driver issue which is separate from your ability to talk to your receiver.


You might want to book mark his YT page as well as Painless360. Between those two people you can solve nearly every problem as they do extensive work reviewing, setting up, and making help videos on nearly every piece of gear related to our hobby.

Yes you can always ask here but its better you learn on your own as at some point you will need the resources to do things on your own once you get full on into the hobby.