• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

PLEASE HELP Naze32 Rev6

#1
i have two naze32 rev 6 boards, one new never flown and one that has been used before. they are both having the same problem. when you hook them up USB only everything seems fine, you can flash firmware and change pid save and reboot no problems. however when you want to calibrate the esc as soon as you hook the lipo up cleanflight freezes, this is extremely frustrating because i cant arm the boards or anything they just sit there flashing.

  • boards hooked to computer with USB only eveything is fine
  • soon as lipo is plugged in clean flight freezes and if you switch between tabs you get waiting on data.
  • if you connect lipo first and then connect USB it will not connect to clean flight.


does anyone know what is going on.
ive tried different computers, USB cables, Cleanflight, Betaflight, Baseflight. nothing works and i can not fly.
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#2
The UBEC in your ESCs is fighting with your computer's USB power, and the computer is likely shutting down the USB port to save it from damage.

The fix is easy-peasy -- remove the red wire from each of the ESC connectors and try again. Dont' cut them off -- after you're done with the calibration and setup you'll have to plug at least one of them back in, so tape them back so they won't short against anything.

Unfortunately that means you're going to have issues with that USB port and powering the Rev6 board via the battery -- only one plugged in at a time -- but that's generally not an issue after you've run the calibration. Whenever you need to connect to the configurator, unplug the battery.
 
#3
i tried that the problem is when i have the red wire from ESC disconnected i have no power to my reciver and when i connect the battery the ESC dont beep, clean flight doesnt freeze but i cant calibrate the anything
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#4
You don't need the RX to calibrate the ESCs -- the signals are all controlled via the motor tab -- but it does seem odd that the ESCs don't beep.

That and the RX not powered when the USB is plugged in, but not battery points to a Rev6A board or later (not that I'd expect most people could spot the difference easily). on the later Rev6 boards the diode protection between the USB and ESCs was put back in. If that's the case then removing the power line from the ESCs is unnecessary.

So . . . Have you tried powering it up with bit the USB and battery with the RX disconnected? Which RX? Which ESCs? Any pics of your setup?
 
#5
what i ended up doing was plugging the ESC into the reciver 1 by 1 and calibrating them with my transmitter, after callibrating them all i then hooked the board back up and all motors work now, im unsure if this will cause any problems, however now im into another problem.

im running the most current Naze32 firmware and updated cleanflight however things appear to be different.
my PID dont have decimal places anymore Example my I use to be .030 and now its 30 and the P use to be 4.5 and now its 45
the quad will not fly with these settings it gitters and shakes uncontrollably.

when i was using cleanflight not to long ago eveything worked normal and PID were displayed as decimal values.

do you by chance know whats going on here?
 

Habakkukk

Fly Eagles, Fly!
#6
When you update firmwares it's always a good idea to retune. Sometimes the update (like this last one) updates the way the pids work. Start with setting I to 0, D to 0 and lowering P until the shaking subsides. Increase D and I as normal. (I'm assuming you tuned it once before)
 
#8
i did take your advice tho and started with P in the pitch and roll at the default 40 and I and D at 0 still shaking and cant maintain a hover, i slowly took the P down in 5's all the way to 10 and still shaking unable to hold heading but i can tell that it is getting sluggish to my inputs trying to keep it stable manually however the jitters will not go. is there something i am missing in this new update or could this board be bad i mean its new and never been flown before.

its like it wants to behave normally as it gets sluggish to inputs as the P gets lower like normal however the whole time its attempting to fly you can hear the motors changing RPM rapidly up and down as it shakes itself out of the air.
 
#10
update

just an update but no good news to report.

given that the build video has come out for the FT210 i watched it and emulated everything in the video given im using the same exact hardware minus transmitter/receiver and fpv equipment. i made sure all hardware was hooked up correctly and switched to betaflight and reflashed with chip erase as in the video and used the all the settings they used within the video (except for transmitter). i recalibrated my ESC just how they did in the video. after completion of rebuild i attempted a hover and same issue persists.

after arming motors spin up but do not spin smoothly they can be heard reving up and down quickly as if you had your P gain to high and were experiencing oscillation, this causes the quad to behave erratically in flight to the point it cant be controlled. ( side note when i re calibrated my ESC in betaflight, when controlling them with Betaflight they will rev up and down and spin smoothly without any jumping in RPM)
one shot 125 is active and I have done some research on what its all about.
At this point im at a total loss for what the problem might be, it seems that a piece of hardware is defective but what it could be im unsure. Considering I followed the build video to a T and used almost all the same equipment bought from the flite test store I shouldn’t have any issue flying. I ordered a Lumenier Lux FC from the flite test store to try a new type of FC.
--Betaflight current Firmware in use, flashed with full chip erase
--Configuration set to Spectrum transmitter so channels are correct
--ESC calibrated through Betaflight same ESC and Motors as in Build Video and calibrated the same way, when controlled in Betaflight everything works and sounds good.
-- PID set to that in the build video (unflyable) set to default (unflyable)