• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Anybody Know How To Keep PWM Settings?

#1
So I was trying to program my flight controller in betaflight today and when I was trying to change the Receiver (in configuration) to PWM, I would hit save and reboot but when it rebooted it changed back to PPM. Does anyone know how to solve this?
 

PsyBorg

Wake up! Time to fly!
#2
You have to go to the ports tab and enable the port you connected your receiver to. Save that page THEN you can go to the configuration page and set the type of receiver. if you set the port and leave without saving it defaults back to last setting.
 

PsyBorg

Wake up! Time to fly!
#4
This should help more visually since this is really old tech now. I do suggest over time you upgrade to newer flight controllers as those are no longer supported not to mention very slow and quirky.

 

ElectriSean

Eternal Student
Mentor
#5
I would try flashing an older version of Betaflight, as the latest versions that supported F3 boards at all had to sacrifice functionality to get them to fit. I imagine PWM support was dropped for this reason, as it's pretty uncommon these days. 3.5.7 or whatever the latest 3.5 was should work fine.
 

PsyBorg

Wake up! Time to fly!
#6
Pretty sure that is the same as the second board I put in my old versa copter when I was learning build and set up. He might actually be better off going with clean flight.